I am implementing it in the Cruna Protocol
@jay In the IERC6551Account interface, we have
function owner() external view returns (address);
In our implementation we allow the user to chose if using an immutable bound account or an upgradeable one that can evolve and in the future accept standard not created yet. In the second scenario, we get a conflict between the owner()
function required by OwnableUpgradeable
and the owner()
function required by IERC6551Account
, i.e., the owner of the smart contract and the owner of the account.
While I like the simplicity of using owner()
, I think it would make our life easier if the name was different.
accountOwner()
or tokenOwner()
would be good alternatives. What do you think?